Which versions of Adobe are compatible with Aquario Design tools?

Published by admin on

Aquario Design runs on the same versions of Adobe that Adobe supports. Adobe recently stopped supporting version 2017 and older, so we only support Adobe CC Versions 2018 and later. For additional information or support, please contact contact@aquariodesign.com

Categories: